ネットワークがプチプチ切れる原因が判明した

いつからか不明だが、Express5800/S70 を使用している時、ネットワークが切断される現象がでるようになった。

ネットワークが切断されると言っても、内部ネットワーク(LAN)は切断されず、外部ネットワーク(WAN)が切断されるようだった。

スポンサードリンク

原因は何処にあるのか

Google Chrome が問題なのか

この現象は特にGoogle Chrome を使用している時に起きた。

Firefox は、タブをクリックするまで読み込まない設定やアドオンがあるが、今のところ、Chrome には無いらしく、再起動すると複数のタブを一気に読み込む。この時点では、複数の通信を確立しようとした負荷によるものらしいと見当を付けたが、それらの処理をCPU が行なってもNIC が行なっても解決しなかった。

また、複数の通信を確立しようとしていない時にもこの現象はおき、例えばNOMACHINE やMSN メッセンジャーなど、常時接続されているアプリケーションが瞬間的に切断される現象が起きた。

これは(複数の通信を確立しようとした時以外では)突然起き、数十秒経過すると回復する。

ただし、アプリケーションによっては自動的に再接続しないものもあるから、手動で再接続する必要があるものもあった。

負荷が問題なのか

さらに、多くの通信を確立しようとしたことが問題かと思っていたが、FTP などの通信を一気に行ってみても問題は起きないらしく、主にHTTP やHPPTS でこの問題は起きるようだ。CPU の負荷が高くなる際に起きるのかとも思ったが、違うようだった。

複雑なネットワークが問題なのか

様々な機器が接続されているから、複雑怪奇なネットワークになっている。また、ネットワーク構成以外にも様々なプロトコルが飛び交うため、何かしら問題が起きても不思議ではない。

例えば、あるメーカーのルーターやHUB は、あるOS の端末を接続するとハングアップしたり、一時的に通信が切断されることがあると製造元の情報を見かけたこともある。

そういうった機器が、動作しているのが不思議なネットワークを構成しているから、原因を突き止める事など無理に思えた。

いよいよ無視できない状態に

しかし、この切断がどうも多くなってきて、無視できない状態になってきた。経験から、本体に問題がないとすると、ドライバ関係かルーター等経路上のものだろうと推測した。

ちなみに、数は少ないが、同機種を利用するユーザーが書き込んだと思われるものを電子掲示板に見つけ、自分だけではないのだろうとも思った。だが、それ以外に書き込みはないから、特定の環境で発生するかも知れないという推測もできる。

解決策を捜す

あまりにも多くの試行錯誤を行ったため、それらを書き記すことはできないが、検索エンジンなどが提示する解決策では、そのすべての組み合わせを試しても解決しなかった。

何をやってもダメ

例えば、ケーブルを交換することや、機器の設定を変更すること、通信設定を変更すること、NIC のフロー制御を変更すること、チェックサムの計算の有無やそれを何処が担当するかを設定すること、OS の通信設定を強制的に変更することなどだ。

ルーターが気になっている

ただ、どうしてもやっぱり気になるのはルーター

なぜなら、通信が切断されても内部通信は基本的に問題ないから。

しかし、ルーターの設定を見なおしても再起動しても何も解決しない。ルーターがLAN からの過剰なアクセスを不正通信としてブロックしている可能性も考えて、ファイアウォールなどの設定も見なおしたが、これも問題なかった。

関係ないがやってみるのも・・

最後の最後、最初に問題を解決しようとしてから時間が経過し、文字通り精も根も尽き果てる状態で、どういうわけか試したのが「ログのクリア」だった。全く関係ないものではあるし、何故クリアしようと思ったのかもわからないが、試した自分がいた。

結果として、これが全てだった。

現在のところ、複数の通信を確立しようとした際や端末のCPU 使用率が極端に上がったりするとプチッとすることはあるが、これは処理が間に合わないだけのことだろうから、通信が切断されるような問題のある状態には一度もなっていない。

変な壊れかた

今回と同じように、経験から見当をつけるような作業が必要になることがある。多くの場合、それはエラーコードなどが正直に表示するものとは全く関係のない部分であることがある。

ターミナルアダプタ

今でも現役であるが、ISDN のTA(ターミナルアダプタ)(V-70DSU)とRS-232C で接続し、制御信号を解析している。早い話が、誰からの着信かをパソコンで表示するCTI のようなシステムが稼働しているのだが、TA からの返答がおかしくなったことがあった。

ただ、通話にも通信にも問題がなく、設定も問題ないし、そもそも変更などしていない。一度初期化して同じ設定をしてもおかしな返答をする現象は解決しなかった。

ところが、TA を変更するとこの問題は解決した。どうやら、TA のRS-232C に関する部分だけがおかしくなってしまったようだ。

その他の機器

それ以外では、グラフィックカードが特定の解像度でのみ故障するという現象も経験したし、ルーターの無線部部だけあるいは有線部分だけもしくは有線LAN の特定のポートだけ壊れるという現象もあった。

予備

なかなか信じられないような現象に遭遇したり壊れ方をするものだなと思う。何かしらのために重要な機器にはバックアップを用意してあるが、誰が見ても壊れたという想定した状態ではない、不思議な現象のときに交換することが多いように思う。

関連記事

スポンサードリンク

Comments

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です